POJ-3259-Wormholes

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 35294 Accepted: 12881

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题目大意是说John从出发点通过一些路径和昆虫洞,最后能返回出发点,并且时间早于出发时间,要求你判断所给的路径和昆虫洞是否能够满足这一要求

其实想明白了以后就是判断是否存在负权回路,我用的Spfa做的;

这里注意一下:path是双向的,wormhole是单向的。

Source

#include <stdio.h>
#include <stdlib.h>
#include <queue>
#include <string.h>
using namespace std;
const int nmax=2505;
const int inf=0xfffffff;
queue<int>q;
struct edge{
	int to;
	int val;
	int next;
	
}edge[nmax*nmax];
int dis[nmax];
int cout[nmax];
int hand[nmax];
int top;
int n,m,w;
void addedge(int f,int t,int v) //静态邻接表
{
	edge[top].to=t;
	edge[top].val=v;
	edge[top].next=hand[f];
	hand[f]=top++;	
}
int spfa(int start)
{
	int i;
	int inqueue[nmax];
	memset(inqueue,0,sizeof(inqueue));
	for(i=0;i<=n;i++)
		dis[i]=inf;
	dis[start]=0;
	memset(cout,0,sizeof(cout));
	int now=1;
	q.push(start);
	cout[start]++;
	inqueue[start]=1;
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		inqueue[now]=0;
		for(i=hand[now];i!=-1;i=edge[i].next)
		{
			int t=edge[i].to;
			int val=edge[i].val;
			if(dis[now]+val<dis[t])
			{
				dis[t]=dis[now]+val;
				if(!inqueue[t])
				{	
					cout[t]++;
					q.push(t);
					inqueue[t]=1;
					if(cout[t]>n)
						return 1;
				}
			}
			
		}
	
	}
	return 0;
	
}
int main()
{
	int t,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&n,&m,&w);
		int a,b,c;
		memset(hand,-1,sizeof(hand));
		top=0;
		while(m--)
		{
			scanf("%d%d%d",&a,&b,&c);//双向的;
			addedge(a,b,c);
			addedge(b,a,c);
		}
		while(w--)
		{
			scanf("%d%d%d",&a,&b,&c);//单向的,把它负的就可以了;
			addedge(a,b,-c);
		}
		if(spfa(1))
			printf("YES\n");//存在负环说明能提前返回。
		else
			printf("NO\n");
	
	}
return 0;	
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值