课程主页在
http://blog.csdn.net/sxhelijian/article/details/39152703,课程资源在
云学堂“贺老师课堂”同步展示,使用的帐号请到课程主页中查看。
输入10个整数存入一维数组,然后按逆序输出。
Input
输入包括一行。
10个以空格隔开的整数。
Output
逆序的10个整数,整数以空格隔开。
Sample Input
1 3 5 9 7 6 8 2 4 0
Sample Output
0 4 2 8 6 7 9 5 3 1
参考解答:
定义好一个有10个元素的数组,先输入9个呈升序的数作为前9个元素,再输入一个数,要求按原来排序的规律将它插入数组中。
Input
第一行,原始数列,9个呈升序的数。第二行,需要插入的数字。
Output
插入后有序的数列
Sample Input
1 7 8 17 23 24 59 62 101
50
Sample Output
7
8
17
23
24
50
59
62
101
统计每个元音字母在字符串中出现的次数。
Input
输入一行长度不超过100的字符串。
Output
输出各个元音字母出现的次数。
Sample Input
my name is ignatius
Sample Output
a:2
e:1
i:3
o:0
u:1
A: 数组逆序输出
Description输入10个整数存入一维数组,然后按逆序输出。
Input
输入包括一行。
10个以空格隔开的整数。
Output
逆序的10个整数,整数以空格隔开。
Sample Input
1 3 5 9 7 6 8 2 4 0
Sample Output
0 4 2 8 6 7 9 5 3 1
参考解答:
#include <iostream>
using namespace std;
int main()
{
int d[10];
int i;
for(i=0; i<10; i++)
cin>>d[i];
for(i=9; i>=0; --i)
cout<<d[i]<<" ";
cout<<endl;
return 0;
}
B: 在有序数组中插入数据
Description定义好一个有10个元素的数组,先输入9个呈升序的数作为前9个元素,再输入一个数,要求按原来排序的规律将它插入数组中。
Input
第一行,原始数列,9个呈升序的数。第二行,需要插入的数字。
Output
插入后有序的数列
Sample Input
1 7 8 17 23 24 59 62 101
50
Sample Output
7
8
17
23
24
50
59
62
101
参考解答:
#include <iostream>
using namespace std;
int main()
{
int d[10];
int i, n;
for(i=0; i<9; i++)
cin>>d[i];
cin>>n; //要插入的数
i = 8;
while(i>=0&&d[i]>n )
{
d[i+1] = d[i];
i--;
}
i++;
d[i] = n;
for(i=0; i<10; ++i)
cout<<d[i]<<endl;
return 0;
}
C: 统计元音字母个数
Description统计每个元音字母在字符串中出现的次数。
Input
输入一行长度不超过100的字符串。
Output
输出各个元音字母出现的次数。
Sample Input
my name is ignatius
Sample Output
a:2
e:1
i:3
o:0
u:1
参考解答:
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int i,sum1=0,sum2=0,sum3=0,sum4=0,sum5=0;
char str[100];
gets(str);
i=0;
while(str[i]!='\0')
{
switch(str[i])
{
case 'a':
++sum1;
break;
case 'e':
++sum2;
break;
case 'i':
++sum3;
break;
case 'o':
++sum4;
break;
case 'u':
++sum5;
break;
}
i++;
}
cout<<"a:"<<sum1<<endl;
cout<<"e:"<<sum2<<endl;
cout<<"i:"<<sum3<<endl;
cout<<"o:"<<sum4<<endl;
cout<<"u:"<<sum5<<endl;
return 0;
}
================= 迂者 贺利坚 CSDN博客专栏============== |== IT学子成长指导专栏 专栏文章的分类目录(不定期更新) ==| |== C++ 课堂在线专栏 贺利坚课程教学链接(分课程年级) ==| |== 我写的书——《逆袭大学——传给IT学子的正能量》 ==| ===== 为IT菜鸟起飞铺跑道,和学生一起享受快乐和激情的大学 =====
|