巧用位运算 ZOJ 3870 Team Formation

Description

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be AB, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. AB > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

要求求出所有两个数组合的^(异或运算)大于两个数中较大的哪一个数的数量。由异或运算的特点(相异为1)可以得出较小数的最高位与较大数异或如果为1那么一定得出的数比较大数大,若果为0肯定比较大数小

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6
 
  
AC代码
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <algorithm>
using namespace std;
typedef pair<string, int> P;
//#define LOCAL
#define INF 0x3f3f3f3f
#define MAX_N 100005

int W[MAX_N], num[MAX_N];

int main()
{
	#ifdef LOCAL
		freopen("b:\\data.in.txt", "r", stdin);
	#endif
    int T;
    cin >> T;
    while(T--)
    {
        memset(W, 0, sizeof(W));
        memset(num, 0, sizeof(num));
        int N;
        cin >> N;
        for(int i = 0; i < N; i++)
        {
            int x;
            cin >> x;
            int cnt = 0;
            while(x>0)
            {
                if(!(x&1))
                {
                    W[cnt]++;
                }
                x = x>>1;
                cnt++;
            }
            num[i] = cnt - 1;//记录第i个输入进来的数的位数
        }
        int ans = 0;
        for(int i = 0; i < N; i++)
        {
            ans += W[num[i]];
        }
        cout << ans << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值