PAT-A1130 Infix Expression 题目内容及题解

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

题目大意

给定一个语法树,要求输出其中缀形式,并用括号表示表达式。

解题思路

  1. 读入语法树,并在读入过程中判断节点是否为操作符(右子树不为空的为操作符);
  2. 找到根节点并进行中序遍历,中序遍历过程中需要注意其是否是操作符以决定是否加括号;
  3. 输出完毕后返回零值。

代码

#include<stdio.h>
#define maxn 30

struct Node{
    int lchild,rchild;
    char data[15];
    int isop;
}node[maxn];

int N,isroot[maxn];

void InOrder(int root){
    if(root==-1){
        return;
    }
    if(node[node[root].lchild].isop){
        printf("(");
        InOrder(node[root].lchild);
        printf(")");
    }else{
        InOrder(node[root].lchild);
    }
    printf("%s",node[root].data);
    if(node[node[root].rchild].isop){
        printf("(");
        InOrder(node[root].rchild);
        printf(")");
    }else{
        InOrder(node[root].rchild);
    }
}


int main(){
    int i,root;
    scanf("%d",&N);
    for(i=1;i<=N;i++){
        scanf("%s",node[i].data);
        scanf("%d%d",&node[i].lchild,&node[i].rchild);
        if(node[i].rchild!=-1){
            node[i].isop=1;
        }else{
            node[i].isop=0;
        }
        if(node[i].lchild!=-1){
            isroot[node[i].lchild]=1;
        }
        if(node[i].rchild!=-1){
            isroot[node[i].rchild]=1;
        }
    }
    for(root=1;root<N;root++){
        if(isroot[root]==0){
            break;
        }
    }
    InOrder(root);
    printf("\n");
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值