1147 Heaps (30分)

1 篇文章 0 订阅

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题⽬⼤意:

给⼀个树的层序遍历,判断它是不是堆,是⼤顶堆还是⼩顶堆并输出这个树的后序遍历

分析:

⾸先根据heap[1]和heap[2]的⼤⼩⽐较判断可能是⼤顶还是⼩顶,分别赋值flag为1和-1,先根据层序遍历,从1~n/2【所有有孩⼦的结点】判断他们的孩⼦是不是满⾜flag的要求,如果有⼀个结点不满⾜,那就将flag=0表示这不是⼀个堆。根据flag输出是否是堆,⼤顶堆还是⼩顶堆,然后后序遍历,根据root分别遍历root2和root2+1,即他们的左右孩⼦,遍历完左右⼦树后输出根结点,即完成了后序遍历
本题参考了大神代码,自己以上来就建堆,结果代码复杂还没写出来

//1147 Heaps (30分)
#include <iostream>
#include <cmath>
using namespace std;
int const maxn=1005;
int m,n;
int heap[maxn];
void postorder(int root)
{
	if(root>n)
	{
		return ;
	}
	postorder(2*root);
	postorder(2*root+1);
	if(root==1)
		cout<<heap[root]<<endl;
	else
		cout<<heap[root]<<" ";
}
int main()
{
	cin>>m>>n;
	for(int i=1; i<=m; i++)
	{
		int flag=1;
		for(int j=1; j<=n; j++)
			cin>>heap[j];
		if(heap[1]<heap[2])
			flag=-1;
		for(int j=1; j<=n/2; j++)
		{
			int left=2*j,right=2*j+1;
			if(flag==1&&(heap[j]<heap[left]||heap[j]<heap[right]&&right<=n))
				flag=0;
			if(flag==-1&&(heap[j]>heap[left]||heap[j]>heap[right]&&right<=n))
				flag=0;
		}
		if(flag == 0)
			cout<<"Not Heap"<<endl;
		else
			printf("%s Heap\n", flag == 1 ? "Max" : "Min");
		postorder(1);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值