HDU--1789 Doing Homework again (贪心)

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

题解:有n门课,每一门课限定在某天前完成和超过时间后罚的分数,规定每天只能完成一门课,问安排怎么时间去完成这些课,使罚分最少并输出最少罚分。

因为希望罚分最少,所以就先考虑罚分多的,然后每考虑一门课,判断期限内的天数能否完成,如果能完成,就将这一天标记,否则计入总罚分。为了别的课也能完成尽量从最后期限开始。

贴代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int x,y;
} mp[1010];
bool cmp(node a,node b)///从罚分最多的课开始。
{
    if(a.y==b.y)
        return a.x<b.x;
    return a.y>b.y;
}
int main()
{
    int t,book[1010];
    scanf("%d",&t);
    while(t--)
    {
        int n,i,j;
        memset(book,0,sizeof(book));
        scanf("%d",&n);
        for(i=0; i<n; i++)
            scanf("%d",&mp[i].x);
        for(i=0; i<n; i++)
            scanf("%d",&mp[i].y);
        sort(mp,mp+n,cmp);
        int sum=0;
        for(i=0; i<n; i++)
        {
            for(j=mp[i].x; j>0; j--)///从期限最后一天开始。
                if(book[j]==0)
                {
                    book[j]=1;
                    break;
                }
            if(j==0)
                sum+=mp[i].y;///无法完成则加入总罚时。
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值