Pots (模拟倒水)

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ i ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input
3 5 4
Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)

POUR(2,1)

问题简述:就是简单的模拟倒水问题,两个杯子有六种情况:fill(1),fill(2),drop(1),drop(2),pour(1,2),pour(2,1)

用bfs分别讨论入队列即可。一开始一直impossible,没注意到在pour的时候先改变x的值后面改变y值时会有影响,记录路径用一个字符数组记 录。

#include<stdio.h>
#include<string.h>
#include<queue> 
#include<iostream>
using namespace std;

const int inf=9999999;
int vis[105][105];
int a,b,c;
int flag;

struct node
{
	int x,y,step;
	char move[110][10];
};
queue<node>Q;

node bfs()
{
	int t;
	node tmp,cur;
	cur.x = 0;
	cur.y = 0;
	cur.step = 0;
	vis[cur.x][cur.y] = 1;
	Q.push(cur);
	
	while(!Q.empty())
	{
		cur = Q.front();
		Q.pop();
		
		if (cur.x==c || cur.y==c)
		{
			flag = 1;
			return cur;
		}
 		//fill 1
		tmp = cur;
		tmp.x = a;
		if (vis[tmp.x][tmp.y]==0)
		{
			vis[tmp.x][tmp.y] = 1;
			strcpy(tmp.move[tmp.step],"FILL(1)");
			tmp.step++;
			Q.push(tmp);
		 } 
		//fill 2
		tmp = cur;
		tmp.y = b;
		if (vis[tmp.x][tmp.y]==0)
		{
			vis[tmp.x][tmp.y] = 1;
			strcpy(tmp.move[tmp.step],"FILL(2)");
			tmp.step++;
			Q.push(tmp);
		 } 
		//drop 1
		tmp = cur;
		tmp.x = 0;
		if (vis[tmp.x][tmp.y]==0)
		{
			vis[tmp.x][tmp.y] = 1;
			strcpy(tmp.move[tmp.step],"DROP(1)");
			tmp.step++;
			Q.push(tmp);
		 } 
		//drop 2
		tmp = cur;
		tmp.y = 0;
		if (vis[tmp.x][tmp.y]==0)
		{
			vis[tmp.x][tmp.y] = 1;
			strcpy(tmp.move[tmp.step],"DROP(2)");
			tmp.step++;
			Q.push(tmp);
		}
		//pour(1,2)
		tmp = cur;
		if (b-tmp.y>tmp.x)
		{
			t = tmp.x;
			tmp.x = 0;
			tmp.y += t;
		}
		else if(b-tmp.y<=tmp.x)
		{
			tmp.x -= (b-tmp.y);
			tmp.y = b;
		}
	
		if (vis[tmp.x][tmp.y]==0)
		{
			vis[tmp.x][tmp.y] = 1;
			strcpy(tmp.move[tmp.step],"POUR(1,2)");
			tmp.step++;
			Q.push(tmp);	
		}
		//pour(2,1)
		tmp = cur;
		if (a-tmp.x>tmp.y)
		{
			tmp.x += tmp.y;
			tmp.y = 0;
		}
		else if (a-tmp.x<=tmp.y)
		{
			t = tmp.x;
			tmp.x = a;
			tmp.y -= (a-t);
		}
		if (vis[tmp.x][tmp.y]==0)
		{
			vis[tmp.x][tmp.y] = 1;
			strcpy(tmp.move[tmp.step],"POUR(2,1)");
			tmp.step++;
			Q.push(tmp);	
		}
	}
} 
 
int main()
{
	while(~scanf("%d%d%d",&a,&b,&c))
	{
		node ans;
		
		memset(vis,0,sizeof(vis));
		flag = 0;
		ans = bfs();
		if (flag)
		{
			printf("%d\n",ans.step);
			for(int i=0; i<ans.step; i++)
				printf("%s\n",ans.move[i]);
		}
		else
			printf("impossible\n");
	}
	return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值