River Hopscotch

Every year thecows hold an event featuring a peculiar version of hopscotch that involves carefullyjumping from  rock to rock in a river.The excitement takes place on a long, straight river with a rock at the startand another rock at the end, Lunits away from the start (1 ≤ L ≤1,000,000,000). Along the river between the starting and ending rocks, N (0≤ N ≤ 50,000) more rocks appear, each at an integraldistance Di from the start (0 < Di < L).

To play the game,each cow in turn starts at the starting rock and tries to reach the finish atthe ending rock, jumping only from rock to rock. Of course, less agile cowsnever make it to the final rock, ending up instead in the river.

Farmer John isproud of his cows and watches this event each year. But as time goes by, hetires of watching the timid cows of the other farmers limp across the short distancesbetween rocks placed too closely together. He plans to remove several rocks inorder to increase the shortest distance a cow will have to jump to reach theend. He knows he cannot remove the starting and ending rocks, but he calculatesthat he has enough resources to remove up to rocks (0≤ M ≤ N).

FJ wants to knowexactly how much he can increase the shortest distance *before* hestarts removing the rocks. Help Farmer John determine the greatest possibleshortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN,and M 
Lines 2.. N+1: Each line contains a single integer indicating howfar some rock is away from the starting rock. No two rocks share the sameposition.

Output

Line 1: A single integer that is the maximum of theshortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2

2

14

11

21

17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jumpof 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, theshortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).



题意:在N+2个数中删除M个数,使之间的最小间隔最小


好吧,说二分,想了很久,就是用最小间隔与最大间隔去中点,然后一个个去除石头,当两块石头间的距离小于mid时就将这两块石头间的石头去掉,直到两块石头间的距离大于等于M,否则最小距离就不是mid,一直取二分


#include<bits/stdc++.h>
using namespace std;

int a[50010];
int L,N,M;

int bsearch(int low,int high)
{
	while(low <= high){
		int mid = (low+high)/2;		//最小移动距离为mid 
		int stone = 0;
		int dis = 0;
		
		for(int i = 1; i <= N+1; i++){
			dis += a[i]-a[i-1];
			if (dis <= mid)		//距离和小于mid时说明这些石头可以移除掉,否则mid不是最小距离 
				stone++;
			else
				dis = 0;
		}
		if (stone <= M)
			low = mid+1;
		else
			high = mid-1; 
	}
	
	return low;
}


int main()
{
	while(~scanf("%d%d%d",&L,&N,&M)){
		int low = 0x3f3f3f3f;
		int high = L;
		a[0] = 0;
		a[N+1] = L;
		
		for(int i = 1; i <= N; i++)
			cin >> a[i];
		sort(a,a+N+2);
		for(int i = 1; i <= N+1; i++)
			low = min(low,a[i]-a[i-1]);
			
		int ans = bsearch(low,high);
		cout << ans << endl;
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值