Combinatorics——HDUOJ 1027 - Ignatius and the Princess II

原题

  • Problem Description

    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, “I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too.” Ignatius says confidently, “OK, at last, I will save the Princess.”
    “Now I will show you the first problem.” feng5166 says, “Given a sequence of number 1 to N, we define that 1,2,3…N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it’s easy to see the second smallest sequence is 1,2,3…N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It’s easy, isn’t is? Hahahahaha……”
    Can you help Ignatius to solve this problem?

  • Input

    The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub’s demand. The input is terminated by the end of file.

  • Output

    For each test case, you only have to output the sequence satisfied the BEelzebub’s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

  • Sample Input

    6 4
    11 8

  • Sample Output

    1 2 3 5 6 4
    1 2 3 4 5 6 7 9 8 11 10

这道题就是对给定的字符集(数字数组:1,2,3……..N)进行全排列,使用字典序法升序,求出第M个排列。
示例:

1 2 3 4 5 6
1 2 3 4 6 5
1 2 3 5 4 6
1 2 3 5 6 4(答案)

解题思路:

  1. 使用非递归方式next_permutation()prev_permutation()得到下一个和上一个的排列组合数组
  2. 使用递归,效率不高,可参考:http://blog.csdn.net/xiazdong/article/details/7986015
  3. next_permutation()原理可参考:http://blog.csdn.net/qq575787460/article/details/41215475

代码:

#include<stdio.h>
#include <algorithm>
using namespace std;
short sum[10001];
int main()
{
    short N, M, i, temp_M;
    while (scanf("%d%d",&N,&M) != EOF)
    {
        temp_M = 1;
        for (i = 0; i < N; i++)//初始化数组
        {
            sum[i] = i + 1;
        }
        while (next_permutation(sum, sum + N))
        {
            temp_M++;
            if (temp_M == M)
            {
                break;
            }
        }
        for (i = 0; i < N; i++)
        {
            if (i == N - 1)
            {
                printf("%d", sum[i]);
            }else
            {
                printf("%d ", sum[i]);
            }
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值