集训队专题(5.1)1006 Channel Allocation

Channel Allocation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 490    Accepted Submission(s): 203


Problem Description
When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.
 

Input
The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 
 

Output
For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.
 

Sample Input
  
  
2 A: B: 4 A:BC B:ACD C:ABD D:BC 4 A:BCD B:ACD C:ABD D:ABC 0
 

Sample Output
  
  
1 channel needed. 3 channels needed. 4 channels needed.
 

Source
 

题意:给出n个中继器的相互直接的相邻关系,且两两连线不会交叉,相邻的中继器不能使用相同的频道接收,问最多需要多少个频道。

首先,不难想到,频道数就等于最大团的顶点数,所以我们直接套小编的最大团模板就可以了。

当然,此题还可以用到一个叫四色原理的方法,四色原理:每个平面地图都可以只用四种颜色来染色,而且没有两个邻接的区域颜色相同。换到我们的顶点图上,只要没有顶点之间连线交叉的情况,我们就可以用到四色原理,由于此题的数据很弱,所以这里小编没有使用这个四色原理进行优化,大家可以自己去尝试一下。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=60;
int g[maxn][maxn],dp[maxn],stk[maxn][maxn],mx;
void dfs(int n,int ns,int dep)
{
	if(ns == 0)
	{
		if(dep > mx) mx = dep;
		return ;
	}
	int i,j,k,p,cnt;
	for(i=0; i<ns; i++)
	{
		k = stk[dep][i];
		cnt = 0;
		if(dep + n - k <= mx) return ;
		if(dep + dp[k] <= mx) return ;
		for(j=i+1; j<ns; j++)
		{
			p = stk[dep][j];
			if(g[k][p]) stk[dep+1][cnt++] = p;
		}
		dfs(n,cnt,dep+1);
	}
	return ;
}
int clique(int n)
{
	int i,j,ns;
	for(mx=0, i=n-1; i>=0; i--)
	{
		for(ns=0, j=i+1; j<n; j++)
			if(g[i][j]) stk[1][ns++] = j;
		dfs(n,ns,1);
		dp[i] = mx;
	}
	return mx;
}
int main()
{
	int n;
	while(scanf("%d",&n)&&n!=0)
	{
		char str[50];
		int i,j;
		memset(g,0,sizeof(g));
		memset(dp,0,sizeof(dp));
		for(i=0; i<n; i++)
		{
			scanf("%s",str);
			for(j=2; str[j]!='\0'; j++)
			{
				int a=str[j]-'A';
				g[i][a] = g[a][i] = 1;
			}
		}
		int ans = clique(n);
		if (ans == 1) puts("1 channel needed.");  
        else printf("%d channels needed.\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值