poj3061 尺取法

27 篇文章 0 订阅

 

如题:http://poj.org/problem?id=3061

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9164 Accepted: 3661

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

 

 

 

题目大意:求给出数组某一段的和大于S,这一段的最小长度。

 

思路:第一种:输入的时候可以预处理求出sum[i]代表1-i个元素的和,然后用s从1-n遍历sum,每一次从s的位置二分搜索出第一个满足条件的区间,算出长度,如果比结果小就更新结果。O(nlogn)

         第二种:第一种方法是固定一端(s),然后搜索满足的尾部t,我们可以头尾一起搜索。

         初始化s=1,t=1,sum=0,如果sum<S,这是先动尾部,s不动,t++,一直到sum>=S,然后让头部++,继续缩小区间,如果不满足,再动尾部。复杂度O(n)。

 

第一种:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define min(a,b)(a<b?a:b)

int T,N,S;
int a[100005];
int sum[100005];

int main()
{
// freopen("C:\\1.txt","r",stdin);
 cin>>T;
 while(T--)
 {
  cin>>N>>S;
  memset(sum,0,sizeof(sum));
  int i;
  for(i=1;i<=N;i++)
  {
   scanf("%d",&a[i]);
   sum[i]+=sum[i-1]+a[i];
  }
  if(sum[N]<S)
  {
   printf("0\n");
   continue;
  }
 int s,res=N;
 for(s=1;sum[N]-sum[s]>=S;s++)
 {
  int t=lower_bound(sum+s,sum+N+1,sum[s]+S)-sum;
  res=min(res,t-s);
 }
 printf("%d\n",res);
 }
}

 

 

第二种:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define min(a,b)(a<b?a:b)

int T,N,S;
int a[100005];

int main()
{
// freopen("C:\\1.txt","r",stdin);
 cin>>T;
 while(T--)
 {
  cin>>N>>S;
  int i;
  int sum=0;
  for(i=1;i<=N;i++)
   scanf("%d",&a[i]);
  int s=1,t=1;
  int res=N;
  while(1)
  {
   while(t<=N&&sum<S)
    sum+=a[t++];
   if(sum<S)
    break;
   res=min(res,t-s);
   sum-=a[s++];
  }
  if(res==N)
   res=0;
  printf("%d\n",res);
 }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值