CD Making

CD Making

Time Limit: 3000/1000MS (Java/Others)    Memory Limit: 65535/65535KB (Java/Others)

Submit Status

Tom has N songs and he would like to record them into CDs. A singleCD can contain at most K songs. In addition, Tom is very superstitious and hebelieves the number 13 would bring bad luck, so he will never let a CD containexactly 13 songs. Tom wants to use as few CDs as possible to recordall these songs. Please help him.

Input

There are T test cases. The first line gives T, number of test cases. T lines follow, each contains N and K, number of songs Tom wants to record into CDs, and themaximum number of songs a single CD can contain.

1≤N≤1000,1≤K≤1000

Output

For each test case, output the minimum number of CDsrequired, if the above constraints are satisfied.

Sample inputand output

Sample Input

Sample Output

2

5 2

13 13

3

2

Hint

If Tom has 5 songs to record and a single CD can contain up to 2 songs, Tom has to use 3 CDs at minimum, each contains 2, 2, 1 songs, respectively.

In the second case, Tom wants to record 13 songs, and a single CD can hold 13 songs at most. He would have been able to use only 1 CD if he were not so superstitious. However, since hewill not record exactly 13 songs into a single CD, he has to use 2 CDs at least, the first contains 12 songs and the second contains one(Other solutions toachieve 2 CDs are possible, such as (11, 2), (10, 3), etc.).

Source

The 5th UESTC Programming Contest Preliminary

 

#include <stdio.h>

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		int n, k, sum=0;
		scanf("%d %d", &n, &k);
		if (k==13 && n>=k)
			sum = n%(k-1)==0?n/(k-1):(n/(k-1)+1);
		else if (k==14 && n>=k && n%k==13)
			sum = n/k+2;
		else
		{
			if (n%k==13&&n<k)
				sum = 2;
			else
				sum = n%k==0?n/k:(n/k+1);
		}	
		printf("%d\n", sum);
	}	
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值