HDU 1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 172698    Accepted Submission(s): 40230


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

我的代码老是超时,估计也是因为开了数组的缘故。

下面是两篇不一样的,我的超时了的,还有的是一个大神的,两个思路不一样。

以下是我的

#include <stdio.h>
#include <string.h>

int main()
{
    int T, N;
    int f[100001];
    int g[100001];
    scanf("%d", &T);
    int count=0;
    while(T--)
    {
        count++;
        scanf("%d", &N);
        for (int i=0; i<N; i++)
        {
            scanf("%d", g+i);
        }
        int max = g[0];
        int s,e;
        s = e = 0;
        for (int i=0; i<N; i++)
        {
            f[0]=g[i];
            for (int j=i+1; j<N; j++)
            {
                f[j] = f[j-1]+g[j];
                
                if (f[j] > max)
                {
                    s = i; e = j;
                    max = f[j];
                }           
            }
        }
        printf("Case %d:\n", count);
        printf("%d %d %d\n\n", max, s+1, e+1);
    } 
        
    return 0;
}

大神的

 #include <iostream>//http://blog.csdn.net/akof1314/article/details/4757021
using namespace std;

int main()
{
	int t,n,temp,pos1,pos2,max,now,x,i,j;
	cin>>t;
	for (i=1;i<=t;i++)
	{
		cin>>n>>temp;
		now=max=temp;
		pos1=pos2=x=1;
		for (j=2;j<=n;j++)
		{
			cin>>temp;
			//以下判断可以写为 if (now<0)
			//所以,如果前面的总和为负,那就从当前的重新开始
            //对于-1, -2, -3的情况,由于前面max设为了-1,所以无错
            //对于-2, -1, -3的情况,由于总和为负所以到temp为-1时会重新开始,
            //且now>max,max=-1,所以无错
            //对于-3, -2, -1的情况,同理。
            //其他更普遍的情况,只要前面总和为负了,就重新开始,且与max比较大小
            //否则,只要前面总和为正或零,就一直加,且在加的过程中把期间最大的值
            //赋给max(如果有的话) 
			if (now+temp<temp)
				now=temp,x=j;
			else
				now+=temp;
			if (now>max)
				max=now,pos1=x,pos2=j;
		}
		cout<<"Case "<<i<<":"<<endl<<max<<" "<<pos1<<" "<<pos2<<endl;
		if (i!=t)
			cout<<endl;
	}
	return 0;
}






下面是两篇不一样的,我的超时了的,还有的是一个大神的,两个思路不一样。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值