hdu 1541 Stars(树状数组,思路)

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7716    Accepted Submission(s): 3059


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0
 

题意:每颗星星的等级是他左下角(不包括自己)的星星个数,问等级0~n-1的星星个数分别为多少

思路:题目中星星是按照y-x递增的顺序给的,那么因为同一位置最多只能有一个星星,所以后面出现的星星肯定在前面的右上角,也就是说,我们大可以不管y了,因为后面的y肯定大于等于前面的。   我们降维,在x轴上维护一个树状数组,因为是从下往上的,逐步更新,每次出现一个新的点(x,y),它的等级就是当前树状数组里面1~x星星的个数

然后再单点更新x点即可。  注意题目坐标是从0开始的,我们的树状数组x坐标最小是1,所以我们要把x改成x+1进行操作。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 40000
int num[N],c[N];
int n;
int lowbit(int x)
{
    return x&-x;
}
void Add(int x,int v)
{
    for(int i=x;i<N;i+=lowbit(i))
        c[i]+=v;
}
int Query(int x)
{
    int ans=0;
    for(int i=x;i;i-=lowbit(i))
        ans+=c[i];
    return ans;
}
int main()
{
    int x,y;
    while(~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        memset(num,0,sizeof(num));
        for(int i=1;i<=n;i++)
        {
            scanf("%d %d",&x,&y);
            num[Query(x+1)]++;
            Add(x+1,1);
        }
        for(int i=0;i<n;i++)
            printf("%d\n",num[i]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值