hdu1003MAX sum(动态规划)

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 183149    Accepted Submission(s): 42725


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 
//hdu-1003(动态规划)
//题目大意:求最大子数组 和;
//解题思路:
// 设sum用来存当前字数组的最大值,result用来存最终结果,stat,end记录子数组的初末位置;
//主要思想就是:如果当前最大和sum小于零时,则该子数组之和一定不是最大;所以此时需要从当前位置从新
//开始往后加,否则将当前的数加入sum中,如此往复,此过程不断更新result; 
//当从第p个数加到 第 i个数时;若前p~i-1个数之和小于零,则将a[i]赋值给sum;
//否则将当前的数a[i]加入sum中;
#include<stdio.h>
#include<string.h>
int a[100001];
int main()
{
	int T,N;
	int i,j,p,sum,result,stat,end;
	int c;
	scanf("%d",&T);
	c=1;
	while(T--)
	{
		memset(a,0,sizeof(a));
		scanf("%d",&N);
		for(i=0;i<N;i++)
		  scanf("%d",&a[i]);
		sum=0,stat=0,end=0;
		result=-1010;
		p=0;
		for(i=0;i<N;i++)
		{
			if(sum<0)
			{                //sum<0,从此位置重新加;并用p记录该位置 ;
				sum=a[i];
				p=i;
			}
			else
			  sum+=a[i];    //否则将a[i]加入sum中; 
			if(sum>result)
			{                    //更新最大值; 
				result=sum;
				stat=p+1;
				end=i+1;
			}
		}
	printf("Case %d:\n%d %d %d\n",c++,result,stat,end);
	if(T!=0)
	 printf("\n");
	}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值