Catch That Cow--bfs 与 优化

18 篇文章 0 订阅
13 篇文章 0 订阅

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

解题报告

最小操作问题,典型用bfs,只是bfs 数据量指数增长会超内存,所以我们要想办法优化。

这个题的有效数据其实就是在[0,2 * K]内,最多2 * K个,所以去除重复数据后的有效数据也就2 * K个,如何去除重复,用bool vis[]记录是否访问,后访问的都是无效的数据,没必要加入队列,那么复杂度就是O(K)了

//BFS Memory Limit Exceeded
#include<stdio.h>
#include<queue>
using namespace std;
int N,K,ans;

int main()
{
    queue<pair<int,int> > que;
    while(~scanf("%d%d",&N,&K)){
        que.push(make_pair(N,0));
        while(true){
            int s=que.front().first,t=que.front().second;que.pop();
            if(s==K){
                printf("%d\n",t);
                break;
            }t++;
            que.push(make_pair(s*2,t));
            que.push(make_pair(s+1,t));
            que.push(make_pair(s-1,t));
        }
        while(!que.empty()) que.pop();
    }
    return 0;
}

对上面代码优化后

//Accepted  1028kb  32ms
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int N,K,ans;
queue<pair<int,int> > que;
bool vis[200010];

int main()
{
    while(~scanf("%d%d",&N,&K)){
        que.push(make_pair(N,0));
        memset(vis,0,sizeof(vis));
        while(true){
            int s=que.front().first,t=que.front().second;que.pop();
            if(s==K){
                printf("%d\n",t);
                break;
            }t++;
            if(s<K){
                if(!vis[s*2]){
                    que.push(make_pair(s*2,t));
                    vis[s*2]=true;
                }
                if(!vis[s+1]){
                    que.push(make_pair(s+1,t));
                    vis[s+1]=true;
                }
            }
            if(s>0&&!vis[s-1]){
                que.push(make_pair(s-1,t));
                vis[s-1]=true;
            } 
        }
        while(!que.empty()) que.pop();
    }
    return 0;
}

某神dfs 解法

这里写图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值