Good Numbers

If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number. 
You are required to count the number of good numbers in the range from A to B, inclusive.
Input
The first line has a number T (T <= 10000) , indicating the number of test cases. 
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
Sample Input
2
1 10
1 20
Sample Output
Case #1: 0
Case #2: 1

        
  
Hint
  
  
The answer maybe very large, we recommend you to use long long instead of int.
思路:不会数位DP,只能找规律。。。
在下不才,,找到了一个规律。连续的十个数肯定就会有一个。也就是0-10,有一个,是0,11-20有一个,是19。
直接用左右区间极值除以10相减就可以了。但是有一点,举个例子说明一下,127和136,与128和136,如果直接按上述算的话,
两组样例结果一样。但是,结果不应该一样,因为在120到130的区间里,有一个符合条件的值是127,在130在140的区间里是136,
所一,要判断区间极值在它所在的小区间里的符合条件的值左边还是右边。。(有点绕)。。。
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<map>
#include<queue>
using namespace std;
typedef long long LL;
int fun(LL x)
{
    int f[20];
    int sum=0,l=0;
    while(x)
    {
        f[l]=x%10;
        x/=10;
        sum+=f[l];
        l++;
    }
    return sum;
}
int main()
{
    int T;
    scanf("%d",&T);
    int q=1;
    while(T--)
    {
        LL a,b,c=0,d=0,num=0;
        scanf("%lld%lld",&a,&b);
        int f1=fun(a/10*10)%10;
        int s1=0;
        if(f1!=0)
            s1=10-f1;
        if(a%10>s1)
            num--;
        int f2=fun(b/10*10)%10;
        int s2=0;
        if(f2!=0)
            s2=10-f2;
        if(b%10>=s2)
            num++;
        c=a/10;
        d=b/10;
        printf("Case #%d: %lld\n",q,num+d-c);
        q++;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值