hud-5776

Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases. 
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO
 

Source



题解:抽屉原理。
当n>m时,有n个前缀和,对m取余就有n个余数,由于n>m,则至少有两个前缀和余数相等,那么相减必之后对m取余必为0.



#include"stdio.h"
#include"cstdio"
#include"algorithm"
#include"string.h"
using namespace std;
const int max_n=5*(1e3)+10;
int A[max_n];
int main()
{
int t;
while(scanf("%d",&t)!=EOF)
{
while(t--)
{
memset(A,0,sizeof(A));
int i,n,m;
scanf("%d%d",&n,&m);
if(n>m)
{
int x;
for(i=0;i<n;i++)
scanf("%d",&x);
printf("YES\n");
}
else
{
int x,flage=0;
for(i=1;i<=n;i++)
{
scanf("%d",&x);
A[i]=A[i-1]+x;
}
for(i=0;i<=n;i++)
{
for(int j=i+1;j<=n;j++)
{
if((A[j]-A[i])%m==0)
{//printf("**%d %d\n",A[j],j);
flage=1;
i=n;
break;
}
}
}
if(flage)
printf("YES\n");
else
printf("NO\n");
}
}
}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值