1741.Jaunt around the Zhuhai Campus

Input:

The first line of the input is a positive integer T.T is the number of the test cases followed.
The first line of each test cases contains only one positive integer N(1

Output:

The output of the program should consist of one line of output for each test case. The output of each test case only contains one real number which represents the area of the cross section of the hills. The real numbers are rounded to one decimal digit. No redundant spaces are needed.

Sample Input

2
2
1 4
3 4
2
2 7
3 9
Sample Output

8.0
8.0

// 以x轴向上的图形,求其面积
// 其中有不同的顶点,可以割分为多个梯形进行求解
#include<iostream>
#include<cmath>
#include<iomanip>
#include<algorithm>
using namespace std;

int main() {
    int t, num;
    double n, m, x, y;
    double result;
    cin >> t;
    while (t--) {
        result = 0;
        cin >> num;
        cin >> n >> m;
        for (int i = 1; i < num; ++i) {
            cin >> x >> y; 
            result += (double)(x - n)*(m + y)/2;
            n = x;
            m = y;
        }
        cout.setf(ios::fixed);
        cout.precision(1);
        cout << result << endl; 
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值