POJ 2531 Network Saboteur(DFS)

Network Saboteur

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90
题目大意:某学校的网络由N个节点组成,每个节点之间交流信息都有一定的代价。将这N个节点分为2组,组内节点交流没有代价,组间交流的代价为Cij的和,要求一个分组方案,使得组间交流的代价最大。

解题思路:开始先将所有节点放在同一组,然后逐个向另一组中添加节点,添加节点到另一组时要注意权值的变化,即应加上原来的组里的所有节点的权值,减去当前组里所有节点的权值,然后记录当前的最大权值并进行下一步搜索,注意将分组标识清除。(对于这种类型的DFS,一定要多加思考!)

代码如下:

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

int net[25][25];
int group[25];
int ans,n,m;

void dfs(int x,int weight)
{
	
	//将x移到1组 
	group[x] = 1;
	int temp = weight;
	//ans = 0;
	
	//变更权值 
	for(int i = 0;i < n;i++){
		if(group[i] == 0)
			temp += net[x][i];
		else
			temp -= net[x][i];
	}
	ans = max(temp,ans);
	for(int i = x + 1;i < n;i++){
		
		 
		if(temp > weight){
			dfs(i,temp);
			group[i] = 0;
		}
	}
} 
 
int main()
{
	int i,j,k;
	while(scanf("%d",&n) != EOF && n ){
		for(i = 0;i < n;i++){
			for(j = 0;j < n;j++){
				scanf("%d",&net[i][j]);
			}
		}
		memset(group,0,sizeof(group));
		ans = 0;
		dfs(0,0);
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值