HDOJ 1253 胜利大逃亡(三维BFS)

胜利大逃亡




Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.


 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
  
  
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output
  
  
11
解题思路:三维BFS,注意bfs函数的返回值,如果没有逃出要返回一个比T大的数,不能返回0。

代码如下:

#include <algorithm>
#include <cctype>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <map>
#include <queue>
#include <set>
#include <stack>
#include <vector>
#define EPS 1e-6
#define INF INT_MAX / 10
#define LL long long
#define MOD 100000000
#define PI acos(-1.0)

struct node
{
    int x;
    int y;
    int z;
    int time;
}p,q,r;
using namespace std;
const int maxn = 55;
int maze[maxn][maxn][maxn];
int dir[6][3] = {{0,0,1},{0,-1,0},{0,0,-1},{0,1,0},{1,0,0},{-1,0,0}};
int A,B,C,T;
int bfs()
{
    p.x = 0,p.y = 0,p.z = 0,p.time = 0;
    queue<node> que;
    que.push(p);
    maze[p.x][p.y][p.z] = 1;
    while(que.size()){
        q = que.front();
        que.pop();
        if(q.x ==  A - 1 && q.y == B - 1 && q.z == C - 1)
            return q.time;

        for(int i = 0;i < 6;i++){
            int nx = q.x + dir[i][0];
            int ny = q.y + dir[i][1];
            int nz = q.z + dir[i][2];
            if(0 <= nx && nx < A && 0 <= ny && ny < B && 0 <= nz && nz < C && maze[nx][ny][nz] != 1){
                r.x = nx;
                r.y = ny;
                r.z = nz;
                r.time = q.time + 1;
                que.push(r);
                maze[r.x][r.y][r.z] = 1;
            }
        }
    }
    return T + 1;
    //这里返回0不对,因为有可能根本没有最短路线,返回0的话后面的判断就会出现错误
    //return 0;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d %d %d %d",&A,&B,&C,&T);
        for(int i = 0;i < A;i++){
            for(int j = 0;j < B;j++){
                for(int k = 0;k < C;k++){
                    scanf("%d",&maze[i][j][k]);
                }
            }
        }
        int ans = bfs();
        printf("%d\n",ans <= T ? ans : -1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值