bzoj1014: [JSOI2008]火星人prefix(Splay)

Description

火星人最近研究了一种操作:求一个字串两个后缀的公共前缀。比方说,有这样一个字符串:madamimadam,
我们将这个字符串的各个字符予以标号:序号: 1 2 3 4 5 6 7 8 9 10 11 字符 m a d a m i m a d a m 现在,
火星人定义了一个函数LCQ(x, y),表示:该字符串中第x个字符开始的字串,与该字符串中第y个字符开始的字串
,两个字串的公共前缀的长度。比方说,LCQ(1, 7) = 5, LCQ(2, 10) = 1, LCQ(4, 7) = 0 在研究LCQ函数的过程
中,火星人发现了这样的一个关联:如果把该字符串的所有后缀排好序,就可以很快地求出LCQ函数的值;同样,
如果求出了LCQ函数的值,也可以很快地将该字符串的后缀排好序。 尽管火星人聪明地找到了求取LCQ函数的快速
算法,但不甘心认输的地球人又给火星人出了个难题:在求取LCQ函数的同时,还可以改变字符串本身。具体地说
,可以更改字符串中某一个字符的值,也可以在字符串中的某一个位置插入一个字符。地球人想考验一下,在如此
复杂的问题中,火星人是否还能够做到很快地求取LCQ函数的值。

Input

  第一行给出初始的字符串。第二行是一个非负整数M,表示操作的个数。接下来的M行,每行描述一个操作。操
作有3种,如下所示
1、询问。语法:Qxy,x,y均为正整数。功能:计算LCQ(x,y)限制:1<=x,y<=当前字符串长度。
2、修改。语法:Rxd,x是正整数,d是字符。功能:将字符串中第x个数修改为字符d。限制:x不超过当前字
符串长度。
3、插入:语法:Ixd,x是非负整数,d是字符。功能:在字符串第x个字符之后插入字符d,如果x=0,则在字
符串开头插入。限制:x不超过当前字符串长度

Output

  对于输入文件中每一个询问操作,你都应该输出对应的答案。一个答案一行。

Sample Input

madamimadam
7
Q 1 7
Q 4 8
Q 10 11
R 3 a
Q 1 7
I 10 a
Q 2 11

Sample Output

5
1
0
2
1

HINT

1、所有字符串自始至终都只有小写字母构成。
2、M<=150,000
3、字符串长度L自始至终都满足L<=100,000
4、询问操作的个数不超过10,000个。
对于第1,2个数据,字符串长度自始至终都不超过1,000
对于第3,4,5个数据,没有插入操作。

题解:Splay维护字符串。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;
typedef unsigned long long ll;
inline int read()
{
    char ch=getchar();int i=0,f=1;
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){i=(i<<3)+(i<<1)+ch-'0';ch=getchar();}
    return i*f;
}
const int Maxn=2e5+50;
const ll G=31;
int n;
ll powG[Maxn];
struct node
{
    node *lc,*rc,*fa;
    ll h,v;
    int sze;
    inline void upt()
    {
        ll lch=this->lc==NULL?0:this->lc->h;
        ll rch=this->rc==NULL?0:this->rc->h;
        int lcs=this->lc==NULL?0:this->lc->sze;
        int rcs=this->rc==NULL?0:this->rc->sze;
        this->h=lch+powG[lcs]*this->v+rch*powG[(lcs+1)];
        this->sze=lcs+rcs+1;
    }
}*rt=NULL,*last;
char ch[Maxn];
inline void build(int l,int r,node *&last,int f)
{
    if(l>r)return;
    node *now=new node();
    if(l==r)
    {
        now->v=now->h=ch[l]-'a'+1;
        now->fa=last,now->sze=1;
        if(l<f)last->lc=now;
        else last->rc=now;
        return;
    }
    int mid=(l+r)>>1;
    build(l,mid-1,now,mid),build(mid+1,r,now,mid);
    now->v=ch[mid]-'a'+1;now->fa=last;now->upt();
    if(mid<f)last->lc=now;
    else last->rc=now;
}
inline bool which(node *x)
{
    return x->fa->lc==x;
}
inline void rotate(node *x,node *&k)
{
    node *y=x->fa,*z=y->fa;
    x->fa=z,y->fa=x;
    if(y==k)k=x;
    else
    {
        if(z->lc==y)z->lc=x;
        else z->rc=x;
    }
    if(y->lc==x)
    {
        if(x->rc)x->rc->fa=y;
        y->lc=x->rc,x->rc=y;
    }
    else
    {
        if(x->lc)x->lc->fa=y;
        y->rc=x->lc,x->lc=y;
    }
    y->upt(),x->upt();
}
inline void splay(node *x,node *&k)
{
    while(x!=k)
    {
        node *y=x->fa,*z=y->fa;
        if(y!=k)
        {
            if(which(x)^which(y))rotate(x,k);
            else rotate(y,k);
        }
        rotate(x,k);
    }
}
inline node *find(node *x,int rk)
{
    int lcs=x->lc==NULL?0:x->lc->sze;
    if(lcs+1==rk)return x;
    else if(lcs>=rk)return find(x->lc,rk);
    else return find(x->rc,rk-lcs-1);
}
inline ll query(int k,int val)
{
    node *x=find(rt,k),*y=find(rt,k+val+1);
    splay(x,rt);splay(y,x->rc);
    return y->lc->h;
}
inline int solve(int x,int y)
{
    int l=1,r=min(rt->sze-x,rt->sze-y)-1;
    while(l<=r)
    {
        int mid=(l+r)>>1;
        if(query(x,mid)==query(y,mid))l=mid+1;
        else r=mid-1;
    }
    return l-1;
}
inline void Insert(int k,int val)
{
    node *x=find(rt,k+1),*y=find(rt,k+2);
    splay(x,rt),splay(y,x->rc);
    node *z=new node();
    z->v=val;z->fa=y;y->lc=z;
    z->upt(),y->upt(),x->upt();
}
int main()
{
    scanf("%s",ch+2);
    powG[0]=1;
    for(int i=1;i<Maxn;i++)powG[i]=powG[i-1]*G;
    n=strlen(ch+2);
    rt=new node();
    int mid=(n+3)>>1;
    rt->v=ch[mid]-'a'+1;rt->sze=1;
    build(1,mid-1,rt,mid),build(mid+1,n+2,rt,mid);
    rt->upt();
    int Q=read();
    char s[2];
    while(Q--)
    {
        scanf("%s",s+1);
        switch(s[1])
        {
            case 'Q':
                {
                    int x=read(),y=read();
                    printf("%d\n",solve(x,y));
                    break;
                }
            case 'I':
                {
                    int x=read();
                    char t;
                    scanf("%c",&t);
                    Insert(x,t-'a'+1);
                    break;
                }
            case 'R':
                {
                    int x=read();
                    char t;
                    scanf("%c",&t);
                    node *y=find(rt,x+1);
                    splay(y,rt);
                    rt->v=t-'a'+1;
                    rt->upt();
                    break;
                }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值