hdu2222:Keywords Search(AC自动机)

Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.

Output
Print how many keywords are contained in the description.

Sample Input
1
5
she
he
say
shr
her
yasherhs

Sample Output
3

题解:ac自动机模板。
对所有串建立ac自动机后用匹配串匹配即可。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;
const int Maxn=1e4+50;
const int L=53;
const int Maxm=1e6+50;
char ch[Maxm];
char s[L];

struct trie
{
    int cnt,fail,vis,son[27];
    inline void init()
    {
        cnt=fail=0;
        memset(son,0,sizeof(son));
    }
}tr[Maxn*L];
int T,n,tt,tot;
inline void Insert()
{
    int now=1;
    int len=strlen(s+1);
    for(int i=1;i<=len;i++)
    {
        int p=s[i]-'a'+1; 
        if(!tr[now].son[p])tr[tr[now].son[p]=++tot].init();
        now=tr[now].son[p];
    }
    tr[now].cnt++;
}
inline void buildfail()
{
    static int que[Maxn*L],qn;
    que[qn=1]=1;
    for(int ql=1;ql<=qn;ql++)
    {
        int u=que[ql];
        for(int j=1;j<=26;j++)
        {
            int v=tr[u].fail,w=tr[u].son[j];
            while(!tr[v].son[j])v=tr[v].fail;
            v=tr[v].son[j];
            if(!w)tr[u].son[j]=v;
            else 
            {
                tr[w].fail=v;
                que[++qn]=w;
            }
        }
    }
} 
long long ans;
int main()
{
    for(int i=1;i<=26;i++)tr[0].son[i]=1;
    scanf("%d",&T);
    for(tt=1;tt<=T;tt++)
    {
        tr[1].init();
        ans=0;
        tot=1;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%s",s+1);
            Insert();
        }
        buildfail();
        scanf("%s",ch+1);
        int now=1,len=strlen(ch+1);
        for(int i=1;i<=len;i++)
        {
            int p=ch[i]-'a'+1;
            now=tr[now].son[p];
            int tmp=now;
            while(tmp&&tr[tmp].vis!=tt)
            {
                tr[tmp].vis=tt;
                ans+=tr[tmp].cnt;
                tmp=tr[tmp].fail;
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值