PAT (Advanced Level) Practice 1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

思路:

  • 模拟stack的过程
  • 首先如果stack为空,那么压入一个数num
  • 如果非空, 读取一个数字, 看栈顶的数字是不是等于这个读取的数, 如果相等弹出栈顶的数, 继续循环; 如果不是, 继续压入数字, 直到相等或者栈的容量大于了最大容量
  • 用一个cnt记录已经读取的数, 如果没有完全读完就判定这种情况是不可行的, 需要继续读完剩下的数, 防止影响下一次判断

AC code

#include<iostream>
#include<stack>
using namespace std;

int main(){
    stack<int> st;
    int m,n,k;
    scanf("%d %d %d",&m,&n,&k);
    
    for(int i=0;i<k;i++){
        while(!st.empty()) st.pop();
        int x,num=1,cnt=0;
        bool flag = true;
        while(num<=n+1){
            if(st.empty()){
                st.push(num++);
            }else{
                scanf("%d",&x); cnt++;
                if(x==st.top()){
                    st.pop();
                }else{
                    while(x!=st.top() and st.size()<m){
                        st.push(num++);
                    }
                    if(x==st.top()) st.pop();
                    else if(st.size()>=m){
                        flag=false;
                        break;
                    }
                }
            }
        }
        for(int i=cnt;i<n;i++) scanf("%d",&x);
        if(flag) printf("YES\n");
        else printf("NO\n");     
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值