PAT (Advanced Level) Practice 1074 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N ( ≤ 1 0 5 ) N (≤10^ 5) N(105) which is the total number of nodes, and a positive K ( ≤ N ) K (≤N) K(N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

思路

  • 同Basic Level B1025 翻转链表

AC code

#include<iostream>
using namespace std;
const int N=100005;
struct pos{
    int data;
    int next;
};
pos p[N];
pos changed[N];
void tackle(int n,int k,int first){
	int timer1=n/k;
	int timer2=n%k;
	int temp=-1;
	if (k==1 && n!=1){   //k==1不用翻转,但n==1时k==1需要翻转
		for (int i=0;i<n;i++){
			if (i==0){
				printf("%05d %d %05d\n",first,changed[i].data,changed[i].next);
			}
            else{
                if (i!=n-1)
                    printf("%05d %d %05d\n",changed[i-1].next,changed[i].data,changed[i].next);
                else
                    printf("%05d %d -1\n",changed[i-1].next,changed[i].data);
            }
		}
		return;
	}
	while(timer1--){
		temp+=k;
		for (int i=temp;i>temp-k;i--){
			if (i==0){
				if (timer1==0){  //不进入下一次循环了 
				    if (timer2==0){
				    	printf("%05d %d -1\n",first,changed[i].data);
					}
					else
					    printf("%05d %d %05d\n",first,changed[i].data,changed[temp].next);
				}
				else{
					printf("%05d %d %05d\n",first,changed[i].data,changed[temp+k-1].next);
				}
			}
			else if (i==1){
				printf("%05d %d %05d\n",changed[i-1].next,changed[i].data,first);
			}
			else if(i==temp-k+1){  //翻转末尾 
				if(timer1==0){  //不进入下一次循环 
					if (timer2==0){
						printf("%05d %d -1\n",changed[i-1].next,changed[i].data);
					}
					else{
						printf("%05d %d %05d\n",changed[i-1].next,changed[i].data,changed[temp].next);
					}
				}
				else{  //进入下一次循环 
					printf("%05d %d %05d\n",changed[i-1].next,changed[i].data,changed[temp+k-1].next);
				}
			}
			else{  //中间的数 
				printf("%05d %d %05d\n",changed[i-1].next,changed[i].data,changed[i-2].next);
			}						
		}
	}
	temp++;
	while(timer2--){
		if (temp==n-1){
			printf("%05d %d -1\n",changed[temp-1].next,changed[temp].data);
		}
		else
		    printf("%05d %d %05d\n",changed[temp-1].next,changed[temp].data,changed[temp].next);
		temp++;
	}	
};
int main(){
    int first,n,k;
    scanf("%d %d %d",&first,&n,&k);
    for(int i=0;i<n;i++){
        int x;
        scanf("%d",&x);
        scanf("%d %d",&p[x].data,&p[x].next);
    }
    int i=0;
    int temp=first;
    do{
        changed[i].data=p[temp].data;
        changed[i].next=p[temp].next;
        temp=p[temp].next;
        i++;
    }while(changed[i-1].next!=-1);
    n=i;
    tackle(n,k,first);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值