【PAT】1004. Counting Leaves (30)【递归】

题目描述:

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

翻译:一个家族按层次经常用家谱(树型结构)来展示。你的任务是计算出这些家族成员哪些人没有孩子。

INPUT FORMAT

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

翻译:每个输入文件包含一组测试数据。每组测试数据的第一行都是N(0 < N < 100)—树的节点数,和M( < N)—有孩子的节 点数。接下来的M行都是以下面的格式:
ID K ID[1] ID[2] … ID[K]
ID是一个两位数字,代表一个非叶子节点,K是它的儿子数量,接下来是一个它的孩子的二位数字数列。为了简单起见,让我们设01为根节点。

OUTPUT FORMAT

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.

翻译:对于每个测试文件,你都需要计算出从根开始每一层次的没有孩子的家庭成员。这些数字必须在一行内输出,用空格隔开,并且行末尾不能有空格。


Sample Input

2 1
01 1 02


Sample Output

0 1


解题思路

先用数组记录成员的父亲和是否为叶子节点,然后通过递归算出其所属的层级,再计算每层的叶子节点。
注意:根节点可能为叶子节点,注意判断。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,M,ccount;
int fa[100];
int h[100];//记录节点为多少层
int v[100];//记录节点是否为叶子节点 
int Count[100];
int find(int t){
    if(h[fa[t]]>0)return h[t]=h[fa[t]]+1;
    else return h[t]=find(fa[t])+1;
}
int main(){
    scanf("%d%d",&N,&M);
    for(int i=0;i<100;i++)fa[i]=-1;
    h[1]=1;
    int a,k;
    for(int i=0;i<M;i++){
        scanf("%d%d",&a,&k);
        v[a]=1;
        int b;
        for(int j=0;j<k;j++){
            scanf("%d",&b);
            fa[b]=a;
        }
    }
    for(int i=0;i<100;i++)if(fa[i]>=0)find(i);
    for(int i=0;i<100;i++){
        if(h[i]){
            if(!v[i])Count[h[i]]++;
            ccount=max(ccount,h[i]);
        }
    }
    printf("%d",Count[1]);
    for(int i=2;i<=ccount;i++){
        printf(" %d",Count[i]);
    } 
    printf("\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值