【PAT】1101. Quick Sort (20)【快速排序】

解题思路

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.

翻译:在著名的快速排序算法中有一个经典的过程叫做分区。在这个过程中,我们通常选择一个元素作为主元。然后小于主元的元素向左移动那些大于主元的元素向右移动。在一次分区后,给定N个不同的正整数,你能说出有多少个元素可以成为这个分区的主元吗?
例如,给定N为5,和数字1,3,2,4和5。我们有:
1可能为主元因为它的左边没有元素且所有它右边的元素都比它大。
3肯定不是主元因为虽然所有它左边的元素都比它小,但是数字2在它的右边且也比它小。
2肯定不是主元因为虽然所有它右边的元素都比它小,但是数字3在它的左边且也比它小。
4和5也可以成为主元,原因类似。
因此总共有3个候选主元。

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

翻译:每个输入文件包含一组测试数据。对于每组测试数据,第一行包括一个正整数N(≤10​5)。接下来一行包括N个不大于109的特定正整数。一行内所有数字之间用空格隔开。

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

翻译:对于每组测试数据,输出一行备选主元的数量。接下来一行,升序输出备选主元。两个相邻数字之间用空格隔开,在每行末尾不能有多余空格。


Sample Input:

5
1 3 2 4 5


Sample Output:

3
1 4 5


解题思路

通过快排原理易知,做一次快排会将主元归位(本题数字均唯一),所以只需要将原数组保存后排序,然后用一个变量记录当前最大值,只要当前数字排序前后位置不变且大于当前最大值,即可判断是主元。注意如果没有主元,仍要输出一行空行。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
#define bug puts("Hello\n")
using namespace std;
int n,before[100010],after[100010],ans[100010];
int main(){
	int n; 
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&before[i]);
		after[i]=before[i];
	}
	sort(after,after+n);
	int ccount=0,maxmin=-1;
	for(int i=0;i<n;i++){
		if(maxmin<before[i])maxmin=before[i];
		else continue;
		if(after[i]==before[i]){
			ans[ccount++]=after[i];
		}
	}
	printf("%d\n",ccount);
	for(int i=0;i<ccount-1;i++){
		printf("%d ",ans[i]);
	}
	if(ccount)printf("%d\n",ans[ccount-1]);
	else printf("\n");//如果为空要输出一行空行 
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值