【PAT】1117. Eddington Number (25)【模拟】

题目描述

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E – that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington’s own E was 87.

Now given everyday’s distances that one rides for N days, you are supposed to find the corresponding E (≤N).

翻译:英国天文学家Eddington喜欢骑自行车。据说,为了炫耀自己的本领,他甚至定义了一个“Eddington数”,即一个人骑了超过E英里的时间为E天的最大整数E。爱丁顿自己的E是87。
现在给定一个人N天的骑车里程,你需要找出相应的E(≤N)。

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

翻译:每个输入文件包含一组测试数据。对于每组测试数据,第一行给定一个正整数N (≤105),表示连续骑行的日子。然后下一行给出N个非负整数,表示每天的骑行距离。

Output Specification:

For each case, print in a line the Eddington number for these N days.

翻译:对于每组测试数据,输出一行N天的Eddington数。


Sample Input:

10
6 7 6 9 3 10 8 2 7 8


Sample Output:

6


解题思路

将数列排序后倒着搜索,当前数字小于E+1时就停止。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
#define bug puts("Hello\n")
using namespace std;
int N,v[100010];
int main(){
	scanf("%d",&N);
	for(int i=0;i<N;i++)scanf("%d",&v[i]);
	sort(v,v+N);
	int E=0; 
	for(int i=N-1;i>=0;i--){
		if(v[i]>E+1)E++;
		else break;
	} 
	printf("%d\n",E);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值