Prime Ring(HDU-1016)

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

    n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

    6

    8

Sample Output

   Case 1: 

   1 4 3 2 5 6
   1 6 5 2 3 4


   Case 2:
   1 2 3 8 5 6 7 4
   1 2 5 8 3 4 7 6
   1 4 7 6 5 8 3 2
   1 6 7 4 3 8 5 2

思路:

  1. 由于要找的是一个环,因此先固定第一个数,再搜索寻找其它的数。
  2. 当找到最后一个数时,需判断与第一个数的和是否为素数。
  3. 注意输出格式,每两个Case间有一空行

Source Program

#include<cmath>
#include<cstdio>
#include<cstring>

int n;
int a[21];
bool vis[21];

bool prime(int n)//判断素数
{
    int i;
    for(i=2;i<=sqrt(n);i++)
        if(n%i==0)
           return false;
    return true;
}

void dfs(int x)
{
    int i;
    if(x==n)//当遍历到a[n-1]后,需要再次递归,此时x==n
    {
        if(prime(1+a[n-1]))//应该计算1与最后数的和是否为素数,若是则输出结果
        {
            printf("1");//输出1
            for(i=1;i<n;i++)//循环输入1后剩余的数
                printf(" %d",a[i]);
            printf("\n");
        }
    }
    for(i=2;i<=n;i++)
    {
        if(vis[i]==1)   continue;//若当前数已使用过,跳过
        if(prime(i+a[x-1]))//判断相邻两元素和是否为素数
        {
            vis[i]=1;//标记为使用
            a[x]=i;//记录当前数
            dfs(x+1);//向下搜索
            vis[i]=0;//回溯
        }
    }
}

int main()
{
    int t=1;

    while(scanf("%d",&n)!=EOF)
    {
        memset(vis,0,sizeof(vis));//用于判断的数组归零
        printf("Case %d:\n",t);
        t++;
        a[0]=1;//初值定义
        dfs(1);
        printf("\n");
    }
    return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值