ZOJ Problem Set - 2770

本文介绍了一个基于差分约束的经典算法问题——火烧连营。该问题源于三国时期的历史故事,通过数学建模转变为现代算法问题。主要内容包括如何利用差分约束系统来估算刘备受挫于陆逊时军队的最小规模,并提供了详细的算法实现步骤和代码。
摘要由CSDN通过智能技术生成
Burn the Linked Camp

Time Limit: 2 Seconds       Memory Limit: 65536 KB

It is well known that, in the period of The Three Empires, Liu Bei, the emperor of the Shu Empire, was defeated by Lu Xun, a general of the Wu Empire. The defeat was due to Liu Bei's wrong decision that he divided his large troops into a number of camps, each of which had a group of armies, and located them in a line. This was the so-called "Linked Camps".

Let's go back to that time. Lu Xun had sent many scouts to obtain the information about his enemy. From his scouts, he knew that Liu Bei had divided his troops into n camps, all of which located in a line, labeled by 1..n from left to right. The ith camp had a maximum capacity of Ci soldiers. Furthermore, by observing the activities Liu Bei's troops had been doing those days, Lu Xun could estimate the least total number of soldiers that were lived in from the ith to the jth camp. Finally, Lu Xun must estimate at least how many soldiers did Liu Bei had, so that he could decide how many troops he should send to burn Liu Bei's Linked Camps.

Input:

There are multiple test cases! On the first line of each test case, there are two integers n (0<n<=1,000) and m (0<=m<=10,000). On the second line, there are n integers C1��Cn. Then m lines follow, each line has three integers i, j, k (0<i<=j<=n, 0<=k<2^31), meaning that the total number of soldiers from the ith camp to the jth camp is at least k.

Output:

For each test case, output one integer in a single line: the least number of all soldiers in Liu Bei's army from Lu Xun's observation. However, Lu Xun's estimations given in the input data may be very unprecise. If his estimations cannot be true, output "Bad Estimations" in a single line instead.

Sample Input:

3 2
1000 2000 1000
1 2 1100
2 3 1300
3 1
100 200 300
2 3 600

Sample Output:

1300
Bad Estimations
 
差分约束:详细资料见差分约束
如果能够理解差分约束和最短路的关系,那么这些题目都非常好解决。
代码:
#include<cstdio>
#include<iostream>
#include<cstring>
#define Maxn 12010
using namespace std;

struct line{
    int u,v,w;
    line(int uu=0,int vv=0,int ww=0):u(uu),v(vv),w(ww){}
}p[Maxn];
int dist[1010];
const int inf=0x3f3f3f3f;
bool bellman(int u,int m,int n){
    for(int i=0;i<=n;i++)
        dist[i]=inf;
    dist[u]=0;
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++){
            int fr=p[j].u,to=p[j].v,w=p[j].w;
            if(dist[fr]!=inf&&dist[fr]+w<dist[to]) dist[to]=dist[fr]+w;
        }
    for(int j=0;j<m;j++){
        int fr=p[j].u,to=p[j].v,w=p[j].w;
        if(dist[fr]!=inf&&dist[fr]+w<dist[to]) return false;
    }
    return true;
}
int main()
{
    int n,m,fr,to,w;
    while(~scanf("%d%d",&n,&m)){
        int tot=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&w);
            p[tot++]=line(i-1,i,w);
            p[tot++]=line(i,i-1,0);
        }
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&fr,&to,&w);
            p[tot++]=line(to,fr-1,-w);
        }
        if(!bellman(n,tot,n)) puts("Bad Estimations");
        else printf("%d\n",-dist[0]);
    }
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值