1023 Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

题意
输入给出一个不超过20位的数,问这个数乘2后,各个数字出现的次数是否和原数字中每个数字出现的次数一样,如果一样就打印Yes,否则No,然后在最后一行输出乘2后的结果

#include<bits/stdc++.h>
using namespace std; 
int mark1[10],mark2[10];
string double_s(string s)
{
	int cnt=0,a[25];//a的大小必须大于20,题目规定输入的数位数<=20,乘2后位数就可能大于20
	memset(a,0,sizeof(a));
	for(int i=s.length()-1;i>=0;i--)
		a[cnt++]=(s[i]-'0')*2;
	string ans;
	for(int i=0;i<cnt;i++)
		if(a[i]>=10)
		{
			a[i+1]+=a[i]/10;
			a[i]%=10;
			if(i==cnt-1)//注意最后一位
				cnt++;
		}
	for(int i=cnt-1;i>=0;i--)
		ans+=(a[i]+'0');
	return ans;
}
int main()
{
	string s;
	cin >> s;
	for(int i=0;i<s.length();i++)
		mark1[s[i]-'0']++;
	string ds;
	ds = double_s(s);
	if(ds.length()!=s.length())
		cout << "No" << endl << ds;
	else
	{
		for(int i=0;i<ds.length();i++)
			mark2[ds[i]-'0']++;
		int flag=1;//包含部分	
		for(int i=0;i<10;i++)
			if(mark1[i]!=mark2[i])
			{
				flag=0;
				break;		
			}
		if(!flag) 
			cout << "No" << endl << ds;
		else
			cout << "Yes" << endl << ds;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值