1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

map就行,可以把默认的less改成greater,这样map的key变成降序操作会方便。

源码:

#include<bits/stdc++.h>

using namespace std;
map<int, double, greater<int> > a, b, c;

int main() {
    int ex;
    double co;
    int k;
    cin >> k;
    int num = 0;
    for (int i = 0; i < k; i++) {
        cin >> ex >> co;
        a[ex] += co;
    }
    cin >> k;
    for (int i = 0; i < k; i++) {
        cin >> ex >> co;
        b[ex] += co;
    }
    for (auto x = a.begin(); x != a.end(); x++) {
        for (auto y = b.begin(); y != b.end(); y++) {
            ex = x->first + y->first;
            co = x->second * y->second;
            int t = c[ex];
            c[ex] += co;
            if (c[ex] == 0 && t != 0)
                num--;
            else if (c[ex] != 0 && t == 0)
                num++;
        }
    }
    cout << num;
    for (auto x = c.begin(); x != c.end(); x++) {
        if (x->second != 0)
            printf(" %d %.1lf", x->first, x->second);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值