Out of Hay(POJ 2395)---最小瓶颈生成树模板题

题目链接

题目描述

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1…N); Bessie starts at Farm 1. She’ll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.
Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she’s only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.
Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she’ll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she’ll have to traverse.

输入格式

  • Line 1: Two space-separated integers, N and M.
  • Lines 2…1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

输出格式

  • Line 1: A single integer that is the length of the longest road required to be traversed.

输入样例

3 3
1 2 23
2 3 1000
1 3 43

输出样例

43

分析

题目大意是给出n 个点 m 条边,每单位的距离需要一加仑的水,每个点都能进行补充,求从1出发到其他各点所需要最少需要携带的加仑数,即求最小生成树的最大边,显然用kruskal算法求解过程中,最后找到的边就是答案,以下是源代码:

源程序

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define MAXN 2005
#define MAXM 10005
#define INF 0x3f3f3f3f
using namespace std;
struct Edge{
	int u,v,w;
	bool operator <(const Edge a)const{
		return w>a.w;
	}
};
int n,m,father[MAXN];
priority_queue<Edge> q;
int find(int x)
{
	if(x==father[x])return x;
	return father[x]=find(father[x]);
}
int kruskal()
{
	for(int i=1;i<=n;i++)father[i]=i;	//初始化
	int res=INF,mst=0;
	while(mst<n-1){	//生成树边数小于n-1 
		int fu=find(q.top().u),fv=find(q.top().v),w=q.top().w;
		q.pop();
		if(fu!=fv){	//不连通 
			res=w;
			mst++;	
			father[fu]=fv; 
		}
	}
	return res;
}
int main()
{
	while(~scanf("%d%d",&n,&m)){
		while(!q.empty())q.pop();	//初始化 
		for(int i=1;i<=m;i++){
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			q.push(Edge{u,v,w});
		}
		printf("%d\n",kruskal());
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值