HDU 1098 Ignatius‘s puzzle(数学推导,一层循环解决)

Ignatius’s puzzle

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5x^13+13x^5+kax,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x) if no exists that a,then print “no”.

Input

The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output

The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Sample Input

11
100
9999

Sample Output

22
no
43

题意: f(x)=5x^13+13x^5+kax,给出k(0<=k<10000),求出最小的a,任意x,使得f(x) % 65 == 0。
我们先假设f(x)=5x^13+13x^5+kax,65 | f(x),
f(x + 1) = f(x)=5*(x + 1)^13+13*(x + 1)^5+ka(x + 1)
展开得:图片
因为含有C13 * 5 = 65, C5 * 13 = 65,所以这些项都可以约掉,而5x13+13x5+kax是f(x),f(x) | 65,所以这些项也可以约掉,只剩下5+13+k*a。要使65 | f(x + 1),只需让65 | (18 + k * a),让a从0到64遍历便可得到答案。

AC代码:

#include <stdio.h>


int main() {
	int k;
	while(scanf("%d", &k) != EOF) {
		int i;
		for(i = 0; i <= 64; i++) {
			if((18 + k * i) % 65 == 0) {
				printf("%d\n", i);
				break;
			}
		}
		if(i == 65) printf("no\n");
	}
	return 0;
}

End

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值