ImportError: No module named cv2问题的解决方法(修改python默认版本)

问题描述

在调用opencv安装包时,会出现 ImportError: No module named cv2 的问题:
请添加图片描述

产生原因

我确定我已经安装了opencv,但为什么还是显示没有此模块。查阅资料后发现是因为安装opencv是会安装到它默认的python版本,而这个python版本与系统默认使用的版本不一致,才会导致找不到模块。

例如我的电脑里安装了python2.7和python3.8两个版本,ubuntu系统启动程序默认使用python2.7,而opencv则安装在python3.8环境中。

解决方法

首先确定你是不是真的没有安装opencv的python支持,可以运行如下代码安装:

sudo pip3 install opencv-python

如果安装完还不能解决问题,看以下步骤

更改系统的默认python版本,改为所使用的高版本。

可以先使用ls /usr/bin/python*查看系统中存在的python版本
请添加图片描述
然后移除软连接,更改python默认版本

sudo rm /user/bin/python
sudo ln -s /usr/bin/python3.5 /usr/bin/python


再次启动之前的程序,正常启动,不再显示ImportError: No module named cv2了!
请添加图片描述

  • 6
    点赞
  • 32
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 6
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Huffiee

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值