A + B Problem II

A + B Problem II

题目链接
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

or each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

题目分析

题目让你输入ab两个数然后输出他们的和,这道题的数据很大,普通的long long也超了;
那只能自己定义数组一个个去加了

代码实现

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<map>
#include<set> 
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<math.h> 
using namespace std;
typedef long long int ll;
const int maxn=1000010;
int main()
{
	int n,n1,z=0;
	string A,B;
	cin>>n;
	n1=n;
	while(n--)
	{
		int a,b,A_len,B_len,C_len;
		cin>>A>>B; 
		string C="";
		A_len=A.size();
		B_len=B.size();
		a=A_len-1;
		b=B_len-1;
		C_len=a>b?a:b;
		int x0=0,x1=0;//分别代表当前位,和进位 
		for(int i=0;i<=C_len;i++)
		{
			if(a>=0&&b>=0)  //两者在该位数上都有
			{
				x0=(A[a]-'0')+(B[b]-'0')+x1;
				x1=x0/10;
				C=char(x0%10+'0')+C;
				--a,--b; 
			}
			else if(a>b) //A还有位数,B没有位数1了
			{
				x0=(A[a]-'0')+x1;
				x1=x0/10;
				C=char(x0%10+'0')+C;
				--a; 
			}
			else  //B还有位数
			{
				x0=(B[b]-'0')+x1;
				x1=x0/10;
				C=char(x0%10+'0')+C;
				--b; 
			} 	 	 
		}
		if(x1>0)//还有一个进位
		{
			C=char(x1+'0')+C; 
		}
		cout<<"Case "<<++z<<":"<<endl<<A<<" + "<<B<<" = "<<C<<endl;
		if(z<n1)
		cout<<endl;
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值