(HDU - 2899)Strange fuction
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7975 Accepted Submission(s): 5470
Problem Description
Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input
2
100
200
Sample Output
-74.4291
-178.8534
题目大意:给定y,当 x∈[0,100] 时,求函数 f(x)=6∗x7+8∗x6+7∗x3+5∗x2−y∗x 的最小值。
思路:三分求解函数最值模板题。
#include<cstdio>
using namespace std;
const double eps=1e-8;
double y;
double f(double x)
{
return 6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x-y*x;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%lf",&y);
double lo=0,hi=100,mid,midmid;
while(hi-lo>eps)
{
mid=(lo+hi)/2.0;
midmid=(hi+mid)/2.0;
if(f(mid)<f(midmid)) hi=midmid;
else lo=mid;
}
printf("%.4f\n",f(lo));
}
return 0;
}