Greatest Common Increasing Subsequence

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output

output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2

题意:找最长公共递增字串长度。

思路:一道dp题,算是找最长上升子序列和最长公共子序列的代码结合版吧,要认真考虑。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int t,n,m,a[1005],b[1005],dp[1005];

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
            scanf("%d",&b[i]);
        for(int i=1;i<=n;i++)
        {
            int tt=0;
            for(int j=1;j<=m;j++)   //dp数组存以b[j]为结尾的公共递增子序列长度
            {
                if(a[i]>b[j] && tt<dp[j])
                    tt=dp[j];      //如果a[i]>b[j],显然存在a[i]的递增子序列长度至少为b[j]+1
                if(a[i]==b[j])
                    dp[j]=tt+1;
            }
        }
        int maxn=-1;
        for(int i=1;i<=m;i++)
            if(maxn<dp[i]) maxn=dp[i];
        printf("%d\n",maxn);
        if(t) printf("\n");        //注意格式
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值