1050. String Subtraction (20)

题目如下:

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.


题目要求从字符串S1中删除所有S2中有的字符,最简单的解决方法就是S1用string,S2用map,然后遍历输出S1,对于S1中的每一个字符,如果map中有,则不输出。

需要注意的是对空格的处理,使用getline(cin,str)可以读取一行,从而实现string中存储带空格字符串,使用getchar()函数可以捕捉到空格和回车,以此输入S2到map。

代码如下:

#include <iostream>
#include <string>
#include <string.h>
#include <stdio.h>
#include <map>

using namespace std;

int main()
{
    string input,del;
    getline(cin,input);
    map<char,int> strs;
    while(1){
        char c = getchar();
        if(c == '\n') break;
        strs[c] = 1;
    }
    for(int i = 0; i < input.length(); i++){
        char c = input[i];
        if(strs.find(c) != strs.end()) continue;
        printf("%c",c);
    }
    cout << endl;
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值