1027 Colors in Mars (20分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

题意

给定3个数,将这三个数转化成13进制数

分析

辗转相除法,求13进制数,然后将对应的余数转化为A~C

注意

输出不足2位前导0

//1027 Colors in Mars (20分)
#include <iostream>
#include <cmath>
#include <stack>
using namespace std;
string change(int x)
{
	string str;
	stack<int> s;
	while(x!=0)
	{
		s.push(x%13);
		x=x/13;
	}
	while(s.size())
	{
		if(s.top()<10)
			str=str+char(s.top()+48);
		else
			str=str+char(s.top()+55);
		s.pop();
	}

	if(str.size()==0)//不足2为前导0 
		str="00";
	else if(str.size()<2)
		str.insert(0,"0");
	return str;
}
int main()
{
	int a,b,c;
	cin>>a>>b>>c;
	cout<<"#"<<change(a)<<change(b)<<change(c);
	return 0;
}

大神极简代码

#include <cstdio>
using namespace std;
int main()
{
	char c[14] = {"0123456789ABC"};
	printf("#");
	for(int i = 0; i < 3; i++)
	{
		int num;
		scanf("%d", &num);
		printf("%c%c", c[num/13], c[num%13]);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值