POJ 1050 To the Max

POJ 1050 To the Max

描述

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

输入

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N2 integers separated by whitespace (spaces and newlines). These are the N2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 500. The numbers in the array will be in the range [-127,127].

输出

Output the sum of the maximal sub-rectangle.

样例输入

 4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1 8  0 -2

样例输出

15

Code:

#include<iostream>
#include<cstdio>
#include<vector>
#include<limits>
#include<algorithm>
#pragma warning(disable:4996)
using namespace std;

int main()
{
	int n; scanf("%d", &n);
	vector<vector<int>> mat(n+1, vector<int>(n+1,0)), sum(n+1, vector<int>(n+1,0));
	for (int i = 1; i <= n; i++) {
		for (int j = 1; j <= n; j++) {
			scanf("%d", &mat[i][j]);
			sum[i][j] = sum[i - 1][j] + mat[i][j];
		}
	}
	int ans = INT32_MIN;
	for (int i = 1; i <= n; i++) // 子矩阵左下角的行数从第i行开始
	{ 
		for (int j = i; j <= n; j++) // 子矩阵右上角的行数从i开始到最后一行
		{ 
			int max1 = 0; //max1 表示当子矩阵左上角行数是i时, 以(j,k)为右上角的子矩阵和的最大值
			for (int k = 1; k <= n; k++) // 子矩阵右上角的列数从第1列开始到最后一列
			{
				int temp = sum[j][k] - sum[i-1][k];
				if (temp + max1 > 0) max1 = temp + max1;
				else max1 = (temp > 0 ? temp : 0);
				ans = max(max1, ans);
			}
		}
	}
	printf("%d\n", ans);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值