Is It A Tree?

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.


这里就是给你一些边看看能不能组成一棵树,判断树的方法有好几个吧,这里用并查集判断,,,感觉并查集能做的事还挺多,,虽然它本身就是棵树,,,

树只有一个根,除了根其他结点的入度都为一,还有这道题的输入有点坑,注意一下,空树也是树,,,还有POJ的“小希的迷宫”,做法一样,输入也有点坑,,,注意0 0的时候输出Yes...

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;
const int N = 10010;

int f[N], deg[N];
bool root[N];

int Find(int x)
{
    if(x != f[x])
        f[x] = Find(f[x]);
    return f[x];
}
void Union(int x, int y)
{
    int fx = Find(x);
    int fy = Find(y);
    if(fx != fy)
        f[fx] = fy;
    root[fy] = 1;
    root[fx] = 0;
}
int main()
{    
    int a, b, k = 1;
    while(~scanf("%d%d", &a, &b))
    {
        if(a == 0 && b == 0)
        {
            printf("Case %d is a tree.\n", k++);
            continue;
        }
        else if(a <= 0 || b <= 0)
            break;
        memset(deg, 0, sizeof(deg));
        memset(root, 0, sizeof(root));
        for(int i = 1; i <= N; i++)
            f[i] = i;
        Union(a, b);
        deg[b]++;
        while(~scanf("%d%d", &a, &b) && a && b)
        {
            Union(a, b);
            deg[b]++;
        }
        bool tree = true;
        int r = 0;
        for(int i = 1; i <= N; i++)
        {
            if(deg[i] > 1)
            {
                tree = false;
                break;
            }
            if(root[i])
                r++;
        }
        if(tree && r == 1)
            printf("Case %d is a tree.\n", k++);
        else
            printf("Case %d is not a tree.\n", k++);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值