LightOJ 1079 Just another Robbery(概率DP)

Just another Robbery

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability P of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output
For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

Case 1: 2
Case 2: 4
Case 3: 6

Note
For the first case, if he wants to rob bank 1 and 2, then the probability of getting caught is 0.02 + (1 - 0.02) * .03 = 0.0494 which is greater than the given probability (0.04). That’s why he has only option, just to rob rank 2.

题意
给出一个期望的概率 P P P,和银行数量 n n n,再给出 n n n个银行的金额和被抓住的概率 p i p_i pi,并且 p i p_i pi是相互独立的。求在低于 P P P的情况下能抢劫的最大金额

题解
概率,01背包
d p [ i ] dp[i] dp[i]表示抢劫金额为 i i i安全的概率,因此我们在输入时将被抓捕的概率转换为安全的概率
状态转移方程: d p [ i ] = m a x ( d p [ i ] , d p [ i − w [ i ] ] ∗ p [ i ] ) dp[i]=max(dp[i],dp[i-w[i]]*p[i]) dp[i]=max(dp[i],dp[iw[i]]p[i])

代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <queue>
#include <cmath>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <cmath>

using namespace std;
#define me(x,y) memset(x,y,sizeof x)
#define MIN(x,y) x < y ? x : y
#define MAX(x,y) x > y ? x : y
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1e4+10;
const ll INF = 0x3f3f3f3f;
const int MOD = 998244353;
const double eps = 1e-06;
const double PI = acos(-1);




int main(){
    int t;
    cin>>t;
    double dp[maxn],p[maxn];
    int w[maxn];
    for(int ca = 1; ca <= t; ++ca){
        double P;
        me(dp,0);
        int n;
        int sum = 0;
        cin>>P>>n;
        P = 1-P;
        for(int i = 1;i <= n; ++i){
            scanf("%d%lf",&w[i],&p[i]);
            p[i] = 1-p[i];
            sum += w[i];
        }
        dp[0] = 1;
        for(int i = 1; i <= n; ++i){
            for(int j = sum; j >= w[i]; --j){
                dp[j] = max(dp[j],dp[j-w[i]]*p[i]);
            }
        }
        int mx = 0;
        for(int i = 1; i <= sum; ++i){
            if(dp[i] > P) mx = i;
        }
        printf("Case %d: %d\n",ca,mx);
    }
    return 0;
}


/*


*/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值