poj 3259 Wormholes (spfa求最短路)

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 27964 Accepted: 10058

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

 

解题思路:首先,应知道图不一定是连通的,只有图中存在负环就输出“YES”。因此,用spfa算法时,如果一次从源点的松弛不能到达所有边,必须把剩下的再用一次spfa算法。

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define N 505
const int inf=10005;
int map[N][N];         //记录点之间关系
int dis[N];       //记录当前点到源点的距离
int mark[N];     //标记该点是否在队列内
int num[N],n;       //记录一次搜索中某点入队的次数
int Min(int a,int b)
{
	return a<b?a:b;
}
int spfa()
{
	int i,s=1;
	queue<int>q;
	memset(num,0,sizeof(num));
	while(1)
	{
		if(q.empty())
		{
			for(i=1;i<=n;i++)        
				if(!num[i])      //若源点没有和所有的点连通,
					break;
			if(i<=n)
			{
				q.push(i);    //则把后面的点入队,在进行一次spfa算法
				memset(mark,0,sizeof(mark));
				memset(num,0,sizeof(num));
				for(;i>0;i--)       
					num[i]=1;      //先把前面的不可到点标记
			}	
			else
				return 0; 
		}
		s=q.front();
		q.pop();
		mark[s]=0;
		for(i=1;i<=n;i++)
		{
			if(dis[i]>dis[s]+map[s][i])
			{
				dis[i]=dis[s]+map[s][i];
				if(!mark[i])
				{
					mark[i]=1;
					num[i]++;
					q.push(i);
					if(num[i]>n)      //存在负环
						return 1;
				}
			}
		}
	}
	return 0;
}
int main()
{
	int T,a,b,c,m,w,i,j;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d",&n,&m,&w);
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
				map[i][j]=inf;           
			dis[i]=inf;            
		}
		while(m--)
		{
			scanf("%d%d%d",&a,&b,&c);
			map[a][b]=Min(map[a][b],c);    //两点存在多条路
			map[b][a]=Min(map[b][a],c);     //bidirectional双向边
		}
		while(w--)
		{
			scanf("%d%d%d",&a,&b,&c);
			map[a][b]=Min(map[a][b],0-c);
		}
		if(spfa())
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值