杭电 acm 1020

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26744    Accepted Submission(s): 11806


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
      
      
2
ABC
ABBCCC
 

Sample Output
      
      
ABC
A2B3C


小开心,一次AC!大笑

不过发现杭电审检有一点不严谨,题目说先输入一个数字作为接下来的用例次数,可是我的程序却出现用例次数无限,即循环,与数字无关,虽然与我初衷有些不同,但却能通

过!哈哈,再找时间修改!先贴AC代码!

#include<stdio.h>
#include<string.h>
int main(){
    char a,a_1;
    int n,i,m,t=1;
    while(scanf("%d\n",&n)!=EOF){
          for(m=0;m<n;m++){
              i=0;
              while(1){
                    a=getchar();
                    i=i+1;
                    if(i==1) a_1=a;
                    if(i>1&&65<=a&&a<=90){
                       if(a_1==a) 
                          t=t+1;
                       if(a_1!=a){
                          if(t==1){
                             printf("%c",a_1);
                             a_1=a;
                          }
                          if(t!=1){
                             printf("%d%c",t,a_1);
                             a_1=a;
                             t=1;
                          } 
                       }    
                    } 
                    if(a<65||a>90){
                       if(t==1){
                          printf("%c\n",a_1);
                          break;
                       }
                       if(t!=1){
                          printf("%d%c\n",t,a_1);
                          break;
                       }
                    }   
              }
          }
    }
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值