C/C++函数指针和函数指针数组的定义及用法

/*-------------------------------------------------------
功能:函数指针和函数指针数组的定义及用法
输入示例:
Input 2 numbers & 1 operator(0-max, 1-min, 2-sum): 1 9 2
输出示例:
10
---------------------------------------------------------
Author: Zhang Kaizhou
Date: 2019-4-3 10:21:45
--------------------------------------------------------*/
#include <iostream>

using namespace std;

int compute(int a, int b, int (* func)(int a, int b));
int max(int a, int b);
int min(int a, int b);
int sum(int a, int b);

int main(){
    int a, b, oper;
    cout << "Input 2 numbers & 1 operator(0-max, 1-min, 2-sum): ";
    cin >> a >> b >> oper;
    int (* pFunc[3])(int a, int b); // 定义一个长度为3的函数指针数组
    pFunc[0] = max;
    pFunc[1] = min;
    pFunc[2] = sum;
    cout << compute(a, b, pFunc[oper]) << endl;

    return 0;
}

int compute(int a, int b, int (* func)(int a, int b)){ // 函数指针的定义语法为:返回值类型 (* 函数名)(形参列表)
    return func(a, b);
}

int max(int a, int b){
    return a >= b ? a : b;
}

int min(int a, int b){
    return a <= b ? a : b;
}

int sum(int a, int b){
    return a + b;
}

  • 0
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值