PAT A1054

2 篇文章 0 订阅
  • 题目:
    Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
    Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:

For each test case, simply print the dominant color in a line.
Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

  • 题目大意
    给出一系列的数,输出这些数中出现次数最多的数

  • 分析
    由于数字的大小超过int类型,将数字当成字符串来处理。
    建立一个string到int的映射map,map里面存储每个数字出现的次数

#include <map>
#include <string>
#include <iostream>
#include <vector>
int m, n;
using namespace std;
int main()
{
    map<string, int> mp;
    vector<string> count1;
    string temp;
    cin >> n >> m;
    for(int i = 0; i < m; i++){             //初始化map,并将string 存储进可变数组count1,一次来当索引
        for(int j = 0; j < n; j++){
            cin >> temp;
            mp[temp] = 0;
            count1.push_back(temp);
        }
    }
    int Max = 0;
    string res;
    for(int i = 0; i < m*n; i++){                          //找出map中出现次数最大的键值
        mp[count1[i]]++;
        if(mp[count1[i]] > Max){
            Max = mp[count1[i]];
            res = count1[i];
        }
    }
    cout << res;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值