HDU 2199 二分

http://acm.hdu.edu.cn/showproblem.php?pid=2199

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

题目大意:给你一个多项式F(x)=8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6-y,从键盘读入y的值,然后让你求F(x)=0的解。(0<=x<=100)

思路:很明显这个函数在[0,100]是递增的,那么无解的情况即函数图像与x轴没有交点,即F(0)>0或F(100)<0。其他情况下是有解的,可以利用二分法得到。初始l=0,r=100,F(mid)>EPS(即>0)则r=mid,反之l=mid,结束的条件是r-l<=EPS。(可设置EPS=1e-12,想设置大一点也行,个人习惯)

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#define EPS 1e-12
using namespace std;

double y;
double Pow(double x,int t);
double cal(double x);
double check();

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf",&y);
		if(cal(100)<0||cal(0)>0)
			printf("No solution!\n");
		else
			printf("%.4f\n",check());
	}
	return 0;
}

double check()
{
	double l=0.0;
	double r=100.0;
	while(r-l>EPS)
	{
		double mid=(l+r)/2;
		if(cal(mid)>EPS)
			r=mid;
		else
			l=mid;
	}
	return l;
}

double cal(double x)
{
	return 8*Pow(x,4)+7*x*x*x+2*x*x+3*x+6-y;
}

double Pow(double x,int t)
{
	double t1=1,t2=x;
	while(t>0)
	{
		if(t&1)
			t1*=t2;
		t2*=t2;
		t/=2;
	}
	return t1;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值