POJ1456 -- Supermarket 贪心与并查集优化

Supermarket

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23758 Accepted: 10415
Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input

4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10
Sample Output

80
185
Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

题目大意

超市卖商品, 每个商品有对应得价值与售卖的截止时间, 每天最多卖一个商品, 问最多能卖多少钱。

题目思路

思路一:按照价值对所有商品排序, 最后一天选择能卖的价值最大的商品, 依此类推。类推时的时间复杂度为O(n2)。

思路二:按照价值对所有商品排序, 选择价值最大的商品, 把他放在截止日期售卖, 并做好标记, 如果已经被标记, 则往前推, 直到找到未被标记的点。找未被标记的点的时间复杂度为O(n),推理的时间复杂度则为O(n2), 使用并查集优化, 可以在O(1)的时间内找到最靠后的未被标记的点。

AC代码

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;

int s[10010];

int find_set(int x) {
	return x == s[x] ? x : s[x] = find_set(s[x]);
}

struct node {
	int val, ddl;
	bool operator <(const node& b)const {
		return val > b.val;
	}
}a[10010];

int main() {
	int n, ans;
	while (~scanf("%d", &n)) {
		ans = 0;
		for (int i = 1; i < 10005; i++) {
			s[i] = i;
		}
		for (int i = 1; i <= n; i++) {
			scanf("%d%d", &a[i].val, &a[i].ddl);
		}
		sort(a + 1, a + 1 + n);
		for (int i = 1; i <= n; i++) {
			int t = find_set(a[i].ddl);
			if (t > 0) {
				ans += a[i].val;
				s[t] = t - 1;
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值