poj3187Backward Digit Sums(dfs)

20 篇文章 0 订阅
Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5673 Accepted: 3287

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

//poj3187(深度优先搜索) 
//题目大意:给你两数n,m;问你从1~n的排列中是否存在一个序列;由该序列相邻两个数相加得到一个
//新序列,不断如此变换直到最终为一个数;如果这个数等于m;并且在满足上述条件下字典序最小;
//就输出该序列;
//解体思路:就是用DFS按从小到大的顺序枚举1~n的排列;当满足上述条件就打印该序列停止搜索。 
#include<cstdio>
#include<cstring>
int a[20],vis[20],n,sum,s,flag;
bool jude(int sum)    //判断1~n的序列中是否能最终变换为m; 
{
	int b[20],j;
	int k=1;
	for(j=1;j<=n;j++) b[j]=a[j];  //将1~n的一个排列放到临时存放的数组b[]中 
	while(k<n)
	{
	 j=1;
	 for(int i=2;i<=n;i++)
	 {
		b[j++]=b[i]+b[i-1];      //不断让序列中相邻两个数相加 
	 }
	 k++;
    }
    if(b[1]==sum) return true;
    else          return false;
}
void dfs(int cur)
{
	if(flag==1) return ;
	if(cur==n+1&&jude(sum)&&flag==0)     //cur==n+1并且满足jude() 
	{
		printf("%d",a[1]);
		for(int i=2;i<=n;i++) printf(" %d",a[i]);  //打印该序列 
		printf("\n");
		flag=1;                    //flag=1,停止搜索。 
		return ;
	}
	else
	{
		for(int i=1;i<=n;i++)
		{
			a[cur]=i;               //从1到n枚举排列 
			if(!vis[i])
			{
				vis[i]=1;
				dfs(cur+1);
				vis[i]=0;
			}
		}
	}
}
int main()
{
	int i,j,k;
	scanf("%d%d",&n,&sum);
	memset(vis,0,sizeof(vis));
	memset(a,0,sizeof(a));     //初始化a[],用来存放1~n的序列; 
	flag=0;
	dfs(1);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值